أكثر

لم يتم العثور على تثبيت QGIS 2.12 و Ubuntu 14.04 SAGA

لم يتم العثور على تثبيت QGIS 2.12 و Ubuntu 14.04 SAGA


التثبيتQGIS 2.12.2 تحديثعلىأوبونتو 14.04.2018منديبيان مضمونppa. عند فتح QGIS ، لاحظت الخطأ التالي تحتمعالجةالتبويب:

مشكلة في تثبيت SAGA: لم يتم العثور على SAGA أو لم يتم تثبيتها بشكل صحيح

إذا قمت بتنفيذsudo apt-get install sagaثم أدركت أن الإصدار المثبت (2.1) غير مدعوم.

لقد تأكدت من مسح QGIS "بشكل صحيح" قبل التثبيت كما في QGIS فشل التثبيت على Ubuntu 14.04

يبحث في الداخل~ / .qgis2 / python / plugins / Processing / algsيبدو أنه تم تثبيت SAGA ... ولكن كيف نجعل QGIS يتعرف عليه؟


اقتراح Per @ wildintellect:

  1. لقد غيرت مصادر الحزمة منqgis.org/debianلأوبونتوجيس، كذلك انا/etc/apt/sources.listيشبه

    deb http://qgis.org/ubuntugis Trusty main deb-src http://qgis.org/ubuntugis trusty main deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main
  2. بعد ذلك قمت بتطهير qgis باستخدامsudo apt-get --purge remove qgis python-qgis qgis-plugin-grass

  3. تطهير الحزم الدخيلة معsudo apt-get autoremove
  4. تحديث المستودعات بامتدادsudo apt-get update
  5. ثبتsudo apt-get install qgis python-qgis qgis-plugin-grass saga(ملاحظةقصة طويلةفي هذا الأمر).

بعد ذلك ، لا مزيد من التحذير من فقدان التثبيت.


شاهد الفيديو: How to install Quantum GIS on Ubuntu 15 QGIS